Kotlin: kotlin version that is used for building with gradle (1.1.2-5) differs from the one bundled into the IDE plugin (1.1.2-4)

Kotlin Programming

Question or issue of Kotlin Programming:

Has anyone solved this issue?

I am using AS 3.0 Canary 4

How to solve this issue?

Solution no. 1:

I followed @Miha_x64’s advice and upgraded the plug-in which solved my problem:


Tools -> Kotlin -> Configure Kotlin Plugin Updates -> Check for updates now

My version of Android Studio is:

Android Studio 3.0.1
Build #AI-171.4443003, built on November 9, 2017

Solution no. 2:

In my case, I converted Java to Kotlin and I have already Kotlin installed with lower version. So I updated it.

Tools -> Kotlin -> Configure Kotlin Plugin Updates then Check for updates now then choose Stable

Kotlin
.

But it didn’t update my version in the build.gradle file automatically. Because it detected a newer version and differs from the old one.

So I manually updated my version to the latest from

ext.kotlin_version = '1.0.0' to ext.kotlin_version = '1.2.41'

buildscript {
    ext.kotlin_version = '1.2.41'

    repositories {
        google()
        jcenter()
    }
    
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.2'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

Solution no. 3:

There’s an issue in Android Studio 3.0 Canary 4 that prevents it from loading the updated version of the Kotlin plugin. You can ignore the warning shown by the Kotlin plugin in build.gradle until a newer version of Android Studio 3.0 is released.

Solution no. 4:

I also had the same issue, I am using Android Studio 3.2.1

Change the Kotlin version of your project build.gradle file(not module build.gradle file) to latest(at the moment it is 1.3.11)

ext.kotlin_version = '1.3.11'

then there will be notification call Kotlin migration, click Run migrations link on the notification.

Solution no. 5:

add this in your build gradle app

apply plugin: 'com.android.application'
apply plugin: 'kotlin-android'
apply plugin: 'kotlin-android-extensions'
apply plugin: 'kotlin-kapt'

Hope this helps!